Smart Plant Care Kit
for Arduino

() seeed:



Gréve
Smart Plant Care Kit
for Arduino

This kit helps build up your own plant care system. It also favors the extensionality to
achieve more applications with just a few adjustments.

The kit implements two functions. One is to detect environment factors affecting plant
growth such as soil moisture, illumination intensity, temperature and air humidity, all
the data detected can be read on OLED display. Another one is to water plants
automatically through the environment monitoring.
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What'’s in the Kit

Part list Function

Grove - Temp & Humidity Sensor To detection the temperature & humidity
Grove - Sunlight Sensor V1.0 To detect illumination intensity

Grove - Water Flow Sensor To detect the speed and volume of water flow
Grove - Moisture Sensor To detect the soil moisture

Grove - Encoder To adjust knob

Grove - OLED Display 1.12" To display parameters

Grove - Button To adjust parameters

Grove - Relay To control water pump

12V DC Water Pump To pump the water

12V Power connector Power connector

Base Shield V2 Expansion board to connect Groves with your Arduino|

Temp & Humidity Sensor

This temperature & humidity sensor provides
temperature and air humidity detection function. As
temperature or air humidity exceeds the limits set, it
will alarm. It has excellent reliability and stability.

Note: this sensor will not work when temperature goes
below 0 in Celsius Degree.

Grove - Relay

The Grove - Relay is a digital normally-open switch
which used to control water pump.

Grove - Moisture Sensor

This Moisture Sensor can be used to detect moisture of
soil in your plant pot. Just insert it into the soil and
then read the data on OLED display. It can also detect
if water volume is necessary at the moment.




Grove - Encoder

This module is an incremental rotary encoder. The
Grove - Encoder has the standard Grove interface and
can be applied to adjust knob.

Grove - OLED Display 1.12"

oLED Display Itisa 16 color grayscale, 128x64 dot matrix OLED

Jeexe display, with Grove compatible 4pin 12C interface.
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Comparing to LCD, OLED screens are more competi-
tive, which has a number of advantages such as high
brightness, self-emission, high contrast ratio, slim
outline, wide view angle, wide temperature range, and
low power consumption. It was used to display
different parameters detected.

Grove - Button

The Grove - Button is a momentary push button. It
contains one independent "momentary on/off" button.
“Momentary” means that the button rebounds on its
own after it is released.

Grove - Sunlight Sensor V1.0

sisas Sunlight sensor is digital optical sensor (Si1145) which
is sensible to visible light, infrared light and ultraviolet
light. It can fetch luminance with 12C communication
to visible light, infrared light and ultraviolet light. As
your plant is over-illuminated detected by sunlight
sensor, this system will alarm you.

Grove - Base shield v2

As an expansion board, Base Shield V2 has many Grove
connectors, making it convenient to plug more
modules. It is compatible with Arduino, which equips
your kit with more extensionality.




f| > i N 12V Water Pump

\ 7 / This is small size, light weight, high efficiency, low

) \ I 4 consumption and low noise water pump.

A & Itis used to pump water from the container to your
\ plant pot.

Grove - Water Flow Sensor

Water flow sensor consists of a plastic valve body, a
water rotor, and a hall-effect sensor. When water flows
through the rotor, rotor rolls. Its speed changes with
different flow rate. The hall-effect sensor outputs the
corresponding pulse signal. It helps you control your
water flow precisely.

Extra Tools

Arduino UNO Board DC Power Supply (12V)

“ARDUINO

Other accessories: screwdriver, glue gun, scissors, vinyl tubing, water container,
etc.



Build A Simple Plant-care System

Assemble water pump circuit

1. Select all parts required to build water pump circuit from this kit: 2V Water
Pump, Grove-Relay, 12V Power Connector, Power Cables.

2. Plug one red wire of water pump into positive terminal of power connector
and fix it with screw.
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3. Plug cable to relay's either J1 port and fix it.

4. Plug black wire of water pump into negative terminal of power connector
and fix them.

5. Plug red wire of water pump into relay's another port of J1 connector.




6. Have a look at the completed connection.

2. Vinyl tubing connection

1. Note: The vinyl tubing (70 cm) is not included in this kit.

2. Slice vinyl tubing into three parts: two long ones and one short. Each of
the two long ones should be about triple times of the short one in length.
The long ones are used to inlet tube and irrigate tube. The short one will
be used to connect the water pump and the water flow sensor.




3. Thumb of rules: you can connect tubes according to arrow symbols on water
pump and water flow sensor.

4. Connect both end of short tube to outlet of water pump and inlet of water
flow sensor. Note: fix inlet of water flow sensor with nut and make sure tube
connected with water pump is tightened.

5. Connect one end of either long tube to inlet of water pump and place the
other end into water container.




6. Connect the other long tube to outlet of water flow sensor and fix them with
knob.

7.To ensure a good irrigation effect, you can make a few holes on the tube and
place it around the plant. Remember to clog the tube output.




3. Grove module connections manner

Modules Port
Grove - OLED Display 1.12" 12C
Grove - Sunlight Sensor V1.0 12C
Grove-Button D2
Grove - Encoder D3
Grove - Water Flow Sensor D5
Grove - Relay D6
Grove - Temp & Humidity Sensor A0
Grove - Moisture Sensor Al

The following figures show layout of all modules and a demo for it.




4. Additional notes

® The project built with this kit should be placed in the environment where dry
and no rain reached, to avoid short circuit.

® Please insert moisture sensor into the center part of flowerpot, and keep it
near to the plant and away from the landing point of water.

E
T~ o

Figure: Moisture sensor should be placed like this.




Software operations

1. Install the Aduino Development Environment

Get a Arduino UNO board and USB cable (Type A to type C).

Download the Arduino IDE
Get the latest version from the Arduino UNO integrated development
environment (IDE).When downloading work finishes, install it on your PC.

Connect the board

The Arduino board automatically draw power from the USB connection to the
computer or an external power supply. Connect A plug to your PCand C plug
to Arduino UNO board.

The green power LED (labelled PWR) should go on.

Install the drivers

® Click on the Start Menu, and open up the Control Panel.

® While in the Control Panel, navigate to System and Security. Next, click on
System. Once the System window is up, open the Device Manager.

® Look under Ports (COM & LPT). You should see a port named "Arduino
(COMx)". If there is no COM & LPT section, look under "Other Devices" for
"Unknown Device".




e Right click on the "Arduino (COMxx)" port and choose the "Update Driver
Software" option.

® Next, choose the "Browse my computer for Driver software" option.
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e Finally, navigate to and select the driver file named "FTDI USB Drivers",
located in the "Drivers" folder in Arduino installation directories. And follow
general windows driver install wizard to complete installation.
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Launch the Arduino IDE
Double-click the Arduino application.

Note: you can change it in the preferences dialog (Click File>Preference) to choose your
personal language.

Add a sample source code

Check that your IDE is well built. Open the LED blink example sketch: File > Examples >
1. Basics > Blink.
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Select your board
You'll need to select the entry in the Tools > Board menu that corresponds to your
Arduino board. We choose Aduino UNO herein.

5 ik A TGS

Fle €4 Skewch ook Help.
ko Format et
aechive Skech
ok ixEncoding & Reload

Seial Monitor astifom

Board: “Ardkina Una” Bonds Marager

Uypad Ardino USB
Uypad Avdine




Select your serial port

Please choose corresponding COM port for your Arduino board, it can be found in
Device manager in the windows Control Panel.

Note: You should choose right one appropriately to your Arduino board.

Flash the program

Now, simply click the "Upload" button in the environment. Wait a few seconds - you
should

See a prompt like following figure shows:

A few seconds after the upload finishes and we assume you use sample Blink, you
should see the pin 13 (L) LED on the board start to blink (in orange). If it does,
congratulations! You've got Arduino up-and-running.

2. Download demo code

We assume you have connected your Arduino board and computer well with USB
(type A to type C)

Download demo code at https://github.com/Seeed-Studio/Gardening_demo_Arduino
Click “Download zip” button on right side of webpage to download all codes.

Decompress the downloaded zip files to C:\Users\Administrator\Documents\Arduino\
and remove “-master” in decompressed file name.
Note you may need to create a new file called Arduino if it does not exist.

Launch Arduino IDE.

Click Sketch>Add file to add Gardening.ino file from C:\Users\Administrator\Docu-
ments\Arduino\Gardening_demo_Arduino \Gardening_demo_Arduino\Gardening
Note: add library. Copy file library under directory C:\Users\Administrator\Docu-
ments\Arduino\Gardening_demo_Arduino \Gardening_demo_Arduino\ to
C:\Users\Administrator\Documents\Arduino\Gardening_demo_Arduino \Garden-
ing_demo_Arduino\Gardening

Press CTRL +U to upload codes to your board. Wait a while, there will be prompt like
following figure:



FAQs:

Q: How should | do if the IDE prompted as “cannot find xxx.h file"?

A: That shows some header files cannot be found be by IDE itself. Click Sketch>Include
Library>Add .zip library to add corresponding header file. For example, you should add
C:\Users\Administrator\Documents\Arduino\Gardening_demo_Ardui-
no-master\Gardening_demo_Arduino-mastenlibraries\OLED_Display_128X64 into
library if IDE have prompted “cannot find OLED.h file".

Get community help at http://support.seeedstudio.com/

mo Operation Instruction

Input interface definition

* Knob, adjust different parameters’ value and switch parameter-setting page.

« Button, control different action to particular event. To be specific, switch temperature
upper and low limits, start or cancel an action and so on.

Attention: Interval of environment factor detection can be configured.

Choose a sensor parameter, press and hold button, then rotate knob to adjust the
values of corresponding parameters.

Attention: For air temperature setting page, there are two parameter which are high
limens and low limens. Once you have pressed button, it will switch parameter to
another. E.g. you are setting high limen and you have pressed down button and then
adjusting knob to change high limen. After stop holding button, press down button
again and rotate knob, you are changing low limen now.

« Start watering immediately.

Switch current page to boot-up which shows as above figure by knob. Press button
once to start water your plants and flowing figure will be displayed which show how
much water have complemented and max limit of water complemented.as water
completed reach the limit, this system will stop watering.



Gardening Demo Water ing
. FlowRate: OL/H
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It also will alarm if no water available in water container and alarming information will
be displayed.

Warning!
NO Water
[ L J

Note: you can always press button to cancel alarming in alarming status.

Note: you can press button to stop watering in watering status.

Note: interval of watering is 5 minutes which means even watering action’s demand is
satisfied, it still needs 5 minutes since last watering.

* Set water volume

You can set water volume complemented for your plant. Switch page to “water
volume” page. Press and hold button, adjust knob to change values. As water
completed reach the limit, this system will stop watering. Default water volume is 0.2L.

WaterVolume
Volume Limen
0.2L
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« Set soil moisture limit.
At moisture setting page, you can set moisture safe value for your plant and check

current moisture magnitude. This system water your plants as moisture magnitude
reach limit. Press and hold button, adjust knob to change values, real moisture value on

upper part, setting value on bottom part of display.

Moisture
0.0%
Safe Value

0. 00%
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¢ Set temperature limits.
At temperature setting page, you can set temperature limits for your plant and check

current temperature. Press button to switch between low limit setting and high limit
setting. Press and hold button, adjust knob to change values, real temperatures index

on upper part, setting value on bottom part of display.

Temperature Temperature
0.0 *C 0.0 *C
< Safe Value <

< Safe Value <

Low —>High
| 0+C
]

Low<- — High

15. 0%C 30, 0*C 15. 0%C 30.
|||||||||||||||||||||||||U u"“"lllllll"ll“lll

Warning! Warning!
Temp High
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* Set air humidity limit.

At humidity setting page, you can set humidity limits for your plant and check current
air humidity. Press button to switch between low limit setting and high limit setting.
Press and hold button, adjust knob to change values, real humidity value on upper part,
setting value on bottom part of display.

Humidity Humidity

0.0 % 0.0 %
< Safe Value < < Safe Value <
Low<- = High Low - “High
60% 50% 60%
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Warning!

Hunidity High
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¢ Set ultraviolet(UV) index limit

At UV index setting page, you can set UV index limits for your plant and check current
UV index, real UV index on upper part, setting value on bottom part of display. Press
and hold button, adjust knob to change values. This system alarm as UV index reach
limit. Default UV index is 9.

W Uit Warning!
0

Safe Value W High
9
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More application expansion

This kit features high extensionality on which you can add more modules to make you
project more intelligent. For example:

* Add a buzzer to alarm yourself;

* Add Bluetooth module to control it more convenient.

Related topics

Smart Plant Care Kit is a smart and inexpensive kit which could help you develop a
plant-caring system quickly. Few and easy modifications are needed if you want to add
more features since it is expanded well. Easy-built plant-caring-system will make your
plants well-attended as you get no time for them.

About Grove

Grove is a modular, ready-to-use tool set that takes a building block approach to
assembling electronics. The Grove system consists of a base shield and a large selection
of modules that feature standardized connectors. The base shield allows for easy
connection of any microcontroller to interface with the various Grove modules. Each
Grove module addresses a unique function & the overall collection of modules expand
a wide range of functionality-from a simple push-button to a complex heart rate sensor.
Each one comes with clear documentation and demo code to help you get started
quickly.

About Seeed Studio

Seeed is a hardware innovation platform for makers to grow inspirations into
differentiating products. Seeed provides accessible technologies with quality, speed
and supply chain knowledge. Seeed helps productize 1 to 1,000 pcs using in-house
engineering, supply chain management and agile manufacture forces. Seeed also
teams up with incubators, China tech ecosystem, investors and distribution channels to
get Maker startups beyond. http://www.seeedstudio.com/depot/

Have Questions?

If you encounter any problem, please refer to the following websites for resources &
help.

For the details of Grove system and Seeed products.
http://www.seeedstudio.com/wiki/Main_Page



Disclaimer

For physical injuries and possessions loss caused by those reasons which are not related
to product quality, such as operating without following manual guide, natural disasters
or force majeure, we take no responsibility for that.

Under the supervision of Seeed Technology Inc., this manual has been compiled and
published which covered the latest product description and specification. The content
of this manual is subject to change without notice.

Appendix

Web links to all the modules:

* Temp & Humidity Sensor: http://www.seeedstudio.com/depot/Grove-Temperature
Humidity-Sensor-HighAccuracy-Mini-p-1921.html

* Water Flow Sensor: http://www.seeedstudio.com/depot/G14-Water-Flow-Sen
sor-p-1345.html

Grove - Moisture Sensor: http://www.seeedstudio.com/depot/Grove-Moisture-Sen
sor-p-955.html

Grove-Encoder: http://www.seeedstudio.com/depot/Grove-Encoder-p-1352.html

Grove - OLED Display 1.12": http://www.seeedstudio.com/depot/Grove-OLED-Dis
play-112-p-781.html

Grove - Button: http://www.seeedstudio.com/depot/Grove-Button-p-766.html

Grove - Relay: http://www.seeedstudio.com/depot/Grove-Relay-p-769.html

12V DC Water Pump: http://www.seeedstudio.com/depot/12V-DC-Wa
ter-Pump-p-1946.html

Base Shield V2: http://www.seeedstudio.com/depot/Base-Shield-V2-p-1378.html



For more information, please visit

seeed.cc/grove




